Skip Navigation LinksCAI > Resources > Help Item

Help

What web browser should I use?

The Crop Adviser Institute site officially supports Internet Explorer 5/6/7, Mozilla Firefox v1 or later, and Safari for Mac OS. If you are experiencing any browser compatibility issues with the site, first make sure that your browser is up to date. If the issues persist, please contact cai@iastate.edu.